The Blinking Red AF Point Debacle (EOS 5D Mark III in AI Servo Mode)

The Blinking Red AF Point Debacle

This is getting irritating, at least. While Canon released a firmware update for the EOS-1D X, they didn’t for the EOS 5D Mark III. Canon Rumors has new information about this issue. Quoting CR (what they have been told):

They are testing that at the moment but don’t know if it is possible to implement. The former system had a different type of focusing screen and it was easy to handle because it had no reflection in the viewfinder. The new system, with the LCD screen inside the viewfinder is reflecting the red light back and this can affect the light metering system. In the EOS-1D X, the viewfinder box is bigger than in EOS 5D Mark III, which aids in making it possible and workable. In the EOS-1D X they alternate red illumination and metering, and this is why there is the red blinking. With the EOS 5D Mark III, they are testing it but they are not sure if they can make it operate in the same way.

Well, what do you think…?

Canon EOS 5D Mark III price check: Amazon | B&H Photo | Digitalrev | eBay | Adorama | Canon USA

 

  • Bob B.

    Maybe Canon could contact…and PAY…the crew at Magic Lantern to sort this out for them (oh…I mean “us”!)??????
    🙂

  • Admin

    To whom it concerns: offending comments will not be published.

    • GreyOwl

      Good move, Admin. Some other sites would also do well to follow your excellent example.

  • Brad

    I knew it was an “issue” when I bought the camera. It wasn’t irritating then, and it’s not now for the kinds of work I do. If they come out with a fix, cool – but that’s just a plus. It’s not like it was a secret or anything.