skip to Main Content

Canon EOS Utility, Tethering, and Mac OS X 10.10 (aka Yosemite)

Photofocus:

The current versions of Canon’s tethering software packages EOS Utility 2 and EOS Utility 3 (for the 1Dx, 5DMK3 and 7DMk2) and their RAW processor Digital Photo Professional are not compatible with the latest version of Mac OS X 10.10 aka Yosemite. I’ve spoken to several Canon technical representatives and public relations people who are quietly aware of the issue. They report they have no information about when these applications will be updated. The workaround for those who tether is to use Lightroom.

Back To Top

Notice

This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the cookie policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the cookie policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.